Excel 2000 n2 - AFCI Newsoft

Transcription

Excel 2000 n2 - AFCI Newsoft
EXCEL XP
I.
II.
Niveau perfectionnement
LES REFERENCES ABSOLUES.................................................................. 4
a)
En utilisant le $ : ............................................................................................. 4
b)
En utilisant les « noms » :.............................................................................. 5
LE COLLAGE SPECIAL ............................................................................... 6
c)
Le collage avec liaison :................................................................................. 6
d)
Le collage avec opérations :.......................................................................... 6
III.
FONCTIONS « SI » IMBRIQUEES ................................................................ 7
IV.
FONCTION DE RECHERCHE :..................................................................... 8
V.
FONCTION VPM : ......................................................................................... 9
VI.
LA VALEUR CIBLE..................................................................................... 10
VII. LES BASES DE DONNEES ........................................................................ 11
a)
Règles de bases............................................................................................ 11
b)
Créer une base de données......................................................................... 11
c)
Le tri simple (1 seule clé) ............................................................................. 12
d)
Le tri multiple (plusieurs clés)..................................................................... 12
e)
Les filtres....................................................................................................... 13
f)
Les sous totaux ............................................................................................ 14
g)
Les tableaux croisés dynamiques (T.C.D.)................................................. 16
VIII. LA CONSOLIDATION ................................................................................. 19
IX.
FORMULE 3D.............................................................................................. 20
X.
LES GRAPHIQUES SUPERPOSES ........................................................... 21
XI.
LES MACROS ............................................................................................. 24
a)
Enregistrer une macro ................................................................................. 24
b)
Affecter une macro à un bouton de commande ........................................ 25
Support de cours AFCI-NEwsoft
3
EXCEL XP
Niveau perfectionnement
I. LES REFERENCES ABSOLUES
a) En utilisant le $ :
Lors de la recopie de calculs, les références des cellules subissent une incrémentation
automatique selon le sens de la recopie (verticale ou horizontale). Ces références de cellules
sont dites « références relatives ».
Vers la droite
Exemple :
Recopie d’un calcul
=A2+B2
Vers le bas
=A3+B3
=B2+C2
Les « références absolues » empêchent l’incrémentation automatique d’une ligne et/ou d’une
colonne, de façon à conserver la référence de cellule d’origine lors de recopie verticale ou
horizontale.
Exemple :
Lors d’une recopie verticale, pour « bloquer » la ligne dans une formule il suffit de rajouter
un $ juste devant ce numéro.
Bloquer la ligne « 2 »
de la référence de
cellule E2 dans le
calcul pour ne pas
qu’elle devienne E3
puis E4 lors de la
recopie verticale.
De la même façon, lors de la recopie horizontale, pour « bloquer » la colonne dans une
formule il suffit de rajouter un $ juste devant cette lettre.
Bloquer la colonne
« A» de la référence
de cellule A5 dans le
calcul pour ne pas
qu’elle devienne B5
puis C5lors de la
recopie horizontale.
Support de cours Afci-Newsoft
4
EXCEL XP
Niveau perfectionnement
b) En utilisant les « noms » :
1. Avant de faire le calcul, Nommer la cellule dont la valeur est en absolu
(valeur constante),
Pour nommer :
Sélectionner la cellule à nommer,
Faire un clic dans la « zone de noms » et saisir le nom
(sans espace et autres caractères génériques)
Taper sur la touche Entrée pour valider
2. Faire le calcul en prenant soin de cliquer sur les cellules à calculer.
Nommer la
cellule D2
« tva »
Remarque :
Tous les noms d’un classeur sont regroupés dans une boite de dialogue que
vous pourrez ouvrir en cliquant sur le menu Insertion / Nom / Définir.
Support de cours AFCI-NEwsoft
5
EXCEL XP
Niveau perfectionnement
II. LE COLLAGE SPECIAL
Cette commande d’EXCEL XP d’effectuer différents collages tels que : collage avec liaison,
collage de mise en forme, collage avec opérations ou même de transposer vos cellules
(lignes en colonnes ou vice versa).
c) Le collage avec liaison :
Permet d’établir une liaison entre 2 cellules dans des feuilles ou classeur
différents.
1.
2.
3.
4.
Sélectionner les cellules à copier,
Cliquer sur l’outil « Copier » ou CTRL C,
Placer le curseur sur la cellule dans la feuille de la destination de la copie,
Dans le menu Edition, choisir Collage spécial…
5. Cliquer sur Coller avec liaison.
d) Le collage avec opérations :
Permet de mettre à jour une plage de cellules numériques.
Exemple : Réduire tous les prix d’un tableau de 5%.
1.
2.
3.
4.
5.
6.
7.
A côté du tableau des prix, saisir la valeur à calculer (ex : 0,95)
Sélectionner cette cellule, cliquer sur l’outil « Copier » ou CTRL C,
Sélectionner la plage de cellules à mettre à jour,
Cliquer sur le menu Edition / Collage spécial…
Sélectionner Valeurs (pour conserver le format original des cellules)
Sélectionner l’opération Multiplication
Cliquer sur OK
Support de cours Afci-Newsoft
6
EXCEL XP
III.
Niveau perfectionnement
FONCTIONS « SI » IMBRIQUEES
Il est possible d’imbriquer jusqu’à 7 fonctions « SI » afin d’élaborer des tests plus complexes.
Exemple : Attribuer une prime selon la grille suivante :
Condition
Prime
Résultat de ventes de 0 à 1000
rien
Résultat de ventes de 1001 à 5000
2% des ventes
Résultat de ventes supérieur à 5000
6% des ventes
1. Placer le curseur dans la cellule résultante (ex : C2)
2. Taper = puis sélectionner la fonction « SI » (ouverture de l’assistant
fonction), puis définir le 1er test ci-dessous :
Cliquez ici pour
ouvrir la fenêtre
du 2ème test
logique
3. Placer le curseur dans l’argument « valeur_si_faux » et Ouvrir une
nouvelle fenêtre pour créer le 2ème test en cliquant sur le bouton de fonctions (à
gauche de la barre de formule)
4. Définir le 2ème test logique ci-dessous, puis OK pour valider.
5. Recopier cette formule, à l’aide de la croix de recopie.
Résultat de la formule :
Support de cours AFCI-NEwsoft
7
EXCEL XP
IV.
Niveau perfectionnement
FONCTION DE RECHERCHE :
La fonction « RECHERCHEV » est une fonction qui permet de trouver une valeur dans la
première colonne d’une table de données et renvoie une valeur de la même ligne d’une
colonne spécifiée de la table de données. Le « V » dans « RECHERCHEV » signifie
« vertical ».
Syntaxe : RECHERCHEV(valeur_cherchée;table_matrice;no_index_col;valeur_proche)
Définition de ces 4 arguments :
Valeur_cherchée :
est la valeur à trouver dans la 1ère colonne de la base de données.
Cet argument peut être une valeur, une référence ou une chaîne de
texte. (ex : un code client ou code article).
Table_matrice :
est la table de données dans laquelle est exécutée la recherche.
De préférence nommer la base de données. (ex : base_clients).
No_index_col :
est le numéro de la colonne de l’argument « table_matrice » (ex : 2)
Valeur_proche :
représente une valeur indiquant si l’on souhaite trouver une valeur
exacte ou voisine de celle spécifiée (ex : taper 0 pour obtenir la
valeur exacte et ne rien saisir pour une valeur proche, soit
immédiatement inférieure à la « valeur cherchée »).
A partir de la table de données ci-dessous, nous allons rechercher le « nom » du client n°7
(valeur_cherchée), Avant de commencer la formule, Nommer la table de données clients.
Cliquer sur la cellule qui contient
la valeur cherchée (7) : J3
Pour coller le nom de la table de
données appuyer sur la touche F3,
sélectionner le nom et OK
Taper 0 pour obtenir
une valeur exacte
Support de cours Afci-Newsoft
Saisir le numéro de la colonne : 2
(car les noms des clients sont en
2ème colonne de la table de
données.
8
EXCEL XP
Niveau perfectionnement
V. FONCTION VPM :
Cette fonction d’EXCEL permet de calculer le remboursement d’un emprunt sur la base de 3
arguments : le taux d’emprunt, la durée de l’emprunt, le capital emprunté.
« VPM » signifie : Valeur du paiement mensuel.
1. Placer le curseur sur la cellule résultante (B4)
2. Taper : = puis sélectionner la fonction « VPM » (à l’aide du bouton placé à
gauche de la « barre de formule »)
Cliquer en B2 pour
définir le taux (diviser
par 12 pour ramener à
une valeur mensuelle)
Cliquer en B3 pour
définir la durée
(multiplier par 12 pour
ramener à une valeur
mensuelle)
Cliquer en B1 pour
définir le capital
emprunté
Résultat de la formule :
Remarque : La
fonction « VPM »
renvoie toujours une
valeur négative
comme résultat
Support de cours AFCI-NEwsoft
9
EXCEL XP
VI.
Niveau perfectionnement
LA VALEUR CIBLE
Permet de trouver la valeur d'un paramètre d'une formule, en fonction d’un résultat que vous
souhaitez atteindre.
Exemple : Avec une fonction « VPM » : De combien sera le capital emprunté si nous ne
disposons que de 150,00 € par mois ?
1. Sélectionner la cellule qui contient la formule « VPM »
2. Dans le menu Outils choisir Valeur cible…
La Cellule à définir (ex : B4) est toujours la cellule qui contient la formule.
La Valeur à atteindre (ex : -150) est le résultat à atteindre pour la formule (à saisir).
La Cellule à modifier (ex : B1) est la cellule qui contient le paramètre à modifier (capital).
Attention !!
Saisir une valeur
négative, car
fonction « VPM »
3. Cliquer sur OK pour valider,
4. Un résultat est alors proposé, cliquer sur OK pour l'accepter.
Vous pouvez utiliser la « valeur cible » avec d’autres fonctions, telles que « moyenne »,
« somme »…
Support de cours Afci-Newsoft
10
EXCEL XP
Niveau perfectionnement
VII. LES BASES DE DONNEES
EXCEL XP vous permet de gérer vos bases de données (fichier clients, fournisseurs, gestion
des stocks, …)
Vous pouvez trier, filtrer, extraire vos données, mais aussi les analyser ou faire des
statistiques.
Vous devez respecter quelques règles imposées par EXCEL XP pour utiliser de façon
optimale les capacités du logiciel.
a) Règles de bases
Dans EXCEL XP, une base de données est un tableau particulier.
1. Il est fortement conseillé de consacrer une feuille de calculs pour une base
de données.
2. La première ligne de la feuille doit contenir les noms de champs (titre des
colonnes)
3. La première colonne doit contenir le premier champ.
4. Le tableau ne doit contenir aucune ligne vide.
5. Le tableau ne doit contenir aucune colonne vide.
b) Créer une base de données
Saisir directement dans une feuille de calculs :
1. Saisir en ligne 1 les noms des champs,
2. Saisir les données en respectant les règles de bases ci-dessus (à partir de la
ligne 2).
A l’aide d’un formulaire
« Masque de saisie »
1. Saisir en ligne 1 les noms des champs,
rendant plus
ère
convivial la saisie
2. Placer le curseur sur la 1 cellule (A1)
des données):
3. Cliquer sur le menu Données / Formulaire…
Utiliser les touches :
« Tabulation » pour
se déplacer vers le bas,
« MAJ Tabulation »
pour remonter.
Permet d’ajouter des données
Supprime la fiche active
Permet de rechercher une fiche
Support de cours AFCI-NEwsoft
11
EXCEL XP
Niveau perfectionnement
c) Le tri simple (1 seule clé)
Permet de trier des données (classer) sur une seule clé de tri (colonne qui sert de critère), il
vous suffit de placer le curseur dans la colonne clé (ne pas faire de sélection) puis de choisir
l’ordre du tri souhaité en cliquant sur un des deux boutons suivants :
Tri croissant
Tri décroissant
d) Le tri multiple (plusieurs clés)
Le tri multiple permet effectuer un tri de vos données (classer) selon plusieurs clés de tri.
1. Placer le curseur sur la 1ère cellule de votre base de données,
2. Dans le menu Données choisir Trier…
3. Sélectionner les champs dans l’ordre de tri souhaité ainsi que le sens de tri
(croissant ou décroissant).
4. Cliquer sur OK pour valider.
Support de cours Afci-Newsoft
12
EXCEL XP
Niveau perfectionnement
e) Les filtres
EXCEL XP vous offre la possibilité de filtrer vos données selon un ou plusieurs critères.
1. Placer le curseur sur la 1ère cellule de votre base de données,
2. Dans le menu Données choisir Filtre puis Filtre automatique.
En haut de chaque colonne, dans les cellules des noms de champs, apparaît des « pointeurs » de listes
déroulantes.
3. Cliquer sur un pointeur et choisir dans la liste le critère du filtre (exemple de
l’illustration ci-dessus : pour le champ « Produits », sélectionner « Laitages »).
Les choix "(10 premiers…) et (Personnalisé…)" permettent d'affiner les critères de filtre.
Exemple d’un filtre personnalisé : « Filtrer les ventes supérieures à 5000 »
Support de cours AFCI-NEwsoft
13
EXCEL XP
Niveau perfectionnement
f) Les sous totaux
Pour analyser vos données suivant des regroupements, EXCEL XP calcule automatiquement
des sous totaux.
Exemple : Calculer la « somme des ventes » par représentant :
Trier les données selon le critère de regroupement (ex : trier par représentant)
2. Dans le menu Données choisir Sous totaux…
1.
3. Cliquer sur OK pour valider (un mode d’affichage « plan » apparaît).
Cliquer sur :
le bouton « 1 »
pour afficher le
total général
le bouton « 2 »
pour afficher les
totaux par
représentant
Support de cours Afci-Newsoft
14
EXCEL XP
Niveau perfectionnement
Cliquer sur :
Le bouton « 3 »
pour afficher tous
les totaux et le
détail des ventes
par représentant
Support de cours AFCI-NEwsoft
15
EXCEL XP
Niveau perfectionnement
g) Les tableaux croisés dynamiques (T.C.D.)
Pour analyser vos données, vous disposez, avec EXCEL XP, d'un outil qui crée des tableaux
croisés dynamiques en quelques étapes à l'aide d'un assistant.
Exemple : Créer un T.C.D. qui affiche la somme des ventes par représentant et par région.
1. Placer le curseur sur la 1ère cellule du tableau,
2. Dans le menu Données choisir Rapport de tableau croisé dynamique…
Etape 1 : Sélectionner la source des données à analyser et le rapport souhaité (tableau croisé
ou graphique).
Etape 2 : Sélectionner la plage cellules de données à utiliser pour le T.C.D. ou Coller un
nom (touche F3) si la base de données a été nommée.
Etape 3 : Cliquer sur le bouton Disposition… pour créer le T.C.D.
Support de cours Afci-Newsoft
16
EXCEL XP
Niveau perfectionnement
Etape 3 (suite) : Disposition du T.C.D.
Faire glisser les « champs »
vers le tableau :
« Ventes » vers DONNEES
« Représentant » vers
COLONNE
Boutons
« champs »
de la base de
données.
« Région » vers LIGNE
Il est impératif de déposer un champ dans le cadre des DONNEES. Les autres cadres peuvent
restés vides.
Dans chaque cadre, vous pouvez déposer plusieurs champs pour faire un tableau très
complet.
La disposition du tableau est modifiable en faisant glisser les champs d'un emplacement à
l'autre.
Cliquez sur OK pour VALIDER.
Cliquer sur Terminer pour insérer le T.C.D. dans une nouvelle feuille.
Pour ajouter un champ dans le
T.C.D., sélectionnez le dans cette
fenêtre puis faites le glisser vers
le T.C.D.
Support de cours AFCI-NEwsoft
17
EXCEL XP
Niveau perfectionnement
Double cliquer
sur ce bouton
pour changer
de fonction.
Double cliquer sur une des
données du T.C.D. revient à
extraire le détail de ces données
dans une nouvelle feuille.
Exemple : double clic sur le résultat
de Davolio région ouest (41934).
La mise en forme du T.C.D. peut être personnalisée tout simplement, comme dans un tableau
"classique".
Vous pouvez également
masquer des éléments en
déroulant la liste du champ
« région » ou « représentant ».
Support de cours Afci-Newsoft
18
EXCEL XP
Niveau perfectionnement
VIII. LA CONSOLIDATION
La consolidation de données permet de regrouper des données de plusieurs tableaux crées
dans des feuilles différentes ou non.
Exemple : Faire la somme des 3 tableaux ci-dessous placés dans des feuilles différentes.
Feuille « région1 »
1. Nommer chacun des 3
tableaux :
région1 ; région2 ; région3
Feuille « région2 »
2. Placer le curseur dans une
nouvelle feuille, puis cliquer
sur le menu Données /
Consolider…
Feuille « région3 »
3. Sélectionner la
fonction « somme »
4. Placer le curseur puis
appuyer sur la touche F3
pour coller le nom du 1er
tableau (région1), puis
cliquer sur « Ajouter »
5. Recommencer
l’étape n°2 deux fois
(région2 ; région3)
6. Cocher les cases :
« Ligne du haut » et
« lier aux données… »
puis Ok pour valider
Support de cours AFCI-NEwsoft
19
EXCEL XP
Niveau perfectionnement
Le résultat de la consolidation est un « tableau » en mode « plan », que vous pouvez mettre en
forme comme un tableau « classique ».
Cliquer sur le 1er ­
pour afficher le détail
(1ères lignes des 3
tableaux)
IX.
FORMULE 3D
Est appelée « formule 3D » une formule qui permet de calculer des données provenant de
feuilles de calculs différentes.
Reprenons l’exemple précédent : Faire le total général des 3 tableaux (région1 ; région2 ;
région3).
1. Placer le curseur dans la cellule résultante,
2. Taper =somme(
3. Cliquer sur l’onglet de la feuille du 1er tableau (région1) puis cliquer sur
la cellule qui contient la valeur à calculer (B9),
4. Taper ;
5. Recommencer depuis l’étape n°3 pour les 2 autres tableaux (région2 ;
région3).
Support de cours Afci-Newsoft
20
EXCEL XP
Niveau perfectionnement
X. LES GRAPHIQUES SUPERPOSES
Ils permettent d’afficher des types de graphiques différents dans un seul et même graphique.
(ex : histogramme et courbe)
Exemple :
Utiliser les
fonctions
« moyenne
» et « max »
(pour la
meilleure
production)
Sélectionner les données (A1:E6), puis cliquer sur l’outil « Assistant graphique »
Etape 1 :
Sélectionner le type de graphique « histogramme groupé » (sans effet 3D) :
Support de cours AFCI-NEwsoft
21
EXCEL XP
Niveau perfectionnement
Etape 2 :
Cocher « série : lignes » :
Etape 3 :
Saisir le titre du graphique « Nombre de pièces fabriquées Mars 2002 » :
Cliquer sur Terminer pour insérer le graphique dans la feuille de calculs.
Dans la barre outils « graphique », sélectionner la « série moyenne »
Support de cours Afci-Newsoft
22
EXCEL XP
Niveau perfectionnement
Cliquer sur le menu Graphique / Type de graphique, sélectionner un type de graphique
« courbe »
Faire de même pour la « série Meilleure production ».
Support de cours AFCI-NEwsoft
23
EXCEL XP
XI.
Niveau perfectionnement
LES MACROS
Pour exécuter rapidement des commandes répétitives, EXCEL XP vous offre la possibilité
d'enregistrer des macros.
a) Enregistrer une macro
1. Dans le menu Outils choisir Macro… puis Nouvelle macro…
Saisir le
nom de la
macro
Sélectionner
« Classeur macros
personnelles » pour
que la macro puisse
être disponible dans
tous vos classeurs !
Saisir le
descriptif de
la macro
2. Cliquer sur OK pour lancer l'enregistrement après avoir rempli les
différentes zones de cette boîte de dialogue,
3. A partir de cet instant toutes vos commandes sont enregistrées
(ex : Cliquer sur le Menu Format / Cellule / onglet « Alignement » : sélectionner
Vertical : Centré + Horizontal : Centré) puis OK pour valider,
4. Cliquer sur le bouton « Arrêter l’enregistrement ».
Support de cours Afci-Newsoft
24
EXCEL XP
Niveau perfectionnement
b) Affecter une macro à un bouton de commande
Une macro peut-être exécutée par un raccourci clavier (voir dans la boîte de dialogue au
dessus) mais également à l'aide d'un bouton que l’on peut placé dans une barre d'outils.
Ajouter un bouton dans une barre d'outils
1. Dans le menu Outils, choisir Personnaliser…
2. Sur l’onglet Commandes, sélectionner la catégorie Macros
3. Faire ensuite glisser le « bouton personnalisé » vers une barre d'outils
Affecter la macro à ce bouton personnalisé :
4. Faire un clic bouton droit de souris sur ce « bouton personnalisé » (en
prenant soin de NE PAS FERMER la fenêtre de « Personnalisation »)
5. Dans le menu contextuel, cliquer sur Affecter une macro
Support de cours AFCI-NEwsoft
25
EXCEL XP
Niveau perfectionnement
6. Sélectionner la macro à affecter.
7. Cliquer sur OK pour valider
Remarque : Tout en conservant la fenêtre de « personnalisation » ouverte, vous pourrez par
le Menu Contextuel (clic droit sur le bouton), accéder à d’autres personnalisations telles que :
Actions
Commandes du menu contextuel à sélectionner
Modifier le nom du bouton
(texte de l’info bulle)
Cliquer sur : Nom :
Changer d’image
Cliquer sur : Modifier l’image du bouton
Dessiner un bouton
Cliquer sur : Editeur de boutons…
Support de cours Afci-Newsoft
26